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• 2x Relays with 10A, 250Vac rated Contacts 

• 2x Open Collector Transistor Outputs  

• 2x Opto-Isolated Digital Inputs 

• 2x 0-10V and 2x 0/4-20mA Inputs 

• 2x 0-10V and 2x 0/4-20mA Outputs 

• 4x General Purpose IO pins 

• Power indicator and serial transmissions LEDs 

• Supports USB Serial, RS-485 and I2C  

• Supports Wi-Fi and Bluetooth 

• Arduino compatible 

• DIN-Rail Mountable Enclosure 

• Dimensions: 145 x 90 x 40 mm 
 
The KTA-332 is an ESP32-powered, Arduino compatible USB or RS-485 controller for interfacing a PC to 
real world applications. The controller is pre-programmed with a custom sketch loaded that listens and 
responds to custom ASCII commands on the USB or RS-485 ports. The sketch is available on Ocean 
Controls website as an example of Arduino programming for the controller.  
 

Specifications: 
 

Parameters Value 

Voltage and Power 5 – 36 VDC; 0.7W 

Operating Temperature -20 – 80 °C  

Default Voltage Output  5Vdc 300mA 

RS485 Communication Setting 1200 – 115200 baud; 8 data bit; No Parity; 1 Stop bit   

USB Communication Setting 1200 – 115200 baud; 8 data bit; No Parity; 1 Stop bit 

I2C Bus Interface Fast mode 400 Kbit/s 

Open Collector Outputs 50Vdc max at 220mA 

Relay output  SPDT 250Vac 8A max* (for a short time) 

Opto-Isolated Digital Input 0 to 30Vdc, ≤2.5 VDC activation threshold 

Analog Inputs 12-bit resolution, ~0.1% accuracy 

Analog Outputs  12-bit resolution, ~0.1% accuracy 
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Connections: 

 

 
 

Name Description 

VIN Positive Supply Voltage (5-36VDC). Reverse Polarity Protected 

GND Negative Supply Voltage / Common Ground 

VOUT Output voltage 5V – 300mA max 

External Antenna External 2.4GHz antenna for KTA-3321 

Micro USB connector For Send/Receiving Commands and Programming (ESP32 UART0) 

I2C 5V-3V VOLTAGE SWITCH I2C voltage selector – choose between 3.3V and 5V 

I2C JST I2C standard JST connector 

SCL I2C Clock Line 

SDA I2C Data Line 

D+ RS-485 Data+ (ESP32 UART1) 

D- RS-485 Data- (ESP32 UART1) 

RELAY1 – COM1, NC1, NO1 Relay 1 Common, Normally Closed and Normally Open Contacts 

RELAY2 – COM2, NC2, NO2 Relay 2 Common, Normally Closed and Normally Open Contacts 

DO1 Open Collector Transistor Output 1 

DO2 Open Collector Transistor Output 2 

DI1+, DI1- Opto-Isolated Input 1 

DI2+, DI2- Opto-Isolated Input 2 

Vout1, Vout2 0-10V Voltage Outputs  

Iout1, Iout2 0-20mA/4-20mA Analog Outputs 

Vin1, Vin2 0-10V Voltage Inputs 

Iin1, Iin2 0-20mA Current Inputs 

GPIO1, GPIO2, GPIO3, GPIO4 General Purpose IO Pins 
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Communicating with the Controller: 
 
The commands the controller uses are in the form: 

@AA CCC X<CR> 
@ symbol is used to define the start of a command. 
AA is the address of the unit from 00 to 99. 
CCC is a three-letter command used to determine the command type. 
X is a one or more characters which determines the parameter for the command.  
<CR> is the carriage return character. This is ASCII character 13, or 0x0d. 
 
Each time a valid command is received the unit will respond with #AA followed by any values that are 
requested from the unit. Note that 00 is the Broadcast Address. All controllers will respond to address 
00 regardless of what their address has been set to.  
 
Note that the unit will automatically ignore any spaces between the command characters. Therefore, 
the command can also be sent as @AACCCX<CR>. 
 
The Address and Baud Rate of the unit can be set and stored in the controller’s non-volatile memory. By 
default, the controller is listening for serial data at 9600 baud and has address 01. The controller will 
always use 1 Stop Bit, 8 Data Bits and No Parity on both USB and RS-485. 
 

Command Set: 
 

Command Function Parameters 

RON Turn Relay On 1-2: Turn Relay 1 and 2 On Individually 
0: Turn All Relays On at Once 

ROF Turn Relay Off 1-2: Turn Relay 1 and 2 Off Individually 
0: Turn All Relays Off at Once 

TON Turn Relay On 1-2: Turn Transistor 1 and 2 On Individually 
0: Turn All Transistors On at Once 

TOF Turn Relay Off 1-2: Turn Transistor 1and 2 Off Individually 
0: Turn All Transistors Off at Once 

ODI Read Status of Opto-
Isolated Inputs 1 and 2 

Return values: 
1: Opto-Isolated Input 1 ON 
2: Opto-Isolated Input 2 ON 
3: Both Opto-Isolated Inputs ON 

CO1 Set Current Output 1 2 decimal points from 0-2000 (mA) 

CO2 Set Current Output 2 2 decimal points from 0-2000 (mA) 

VO1 Set Voltage Output 1 2 decimal points from 0-1000 (V) 

VO2 Set Voltage Output 2 2 decimal points from 0-1000 (V) 

CI1 Read Current Input 1 Return value with 2 decimal points from 0-2000 (mA) 

CI2 Read Current Input 2 Return value with 2 decimal points from 0-2000 (mA) 

VI1 Read Voltage Input 1 Return value with 2 decimal points from 0-1000 (V) 

VI2 Read Voltage Input 2 Return value with 2 decimal points from 0-1000 (V) 

SAD Set Address 01-99: Sets the Address of the unit in Memory 
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SBR Set Baud Rate 1-10: Sets the Baud Rate  

1: 1200 baud 6: 19200 baud 

2: 2400 baud 7: 28800 baud 

3: 4800 baud 8: 38400 baud 

4: 9600 baud (default) 9: 57600 baud 

5: 14400 baud 10: 115200 baud 
 

 
RON: Relays ON Command 
This command is used to turn a single relay or both relays ON.  
E.g.: @01 RON 1 will turn Relay 1 ON and @01 RON 2 will turn Relay 2 ON for the unit with address 01. It 
can also be used to turn both Relays ON by setting the parameters to be 0: @01 RON 0.  
 
ROF: Relays OFF Command 
This command is used to turn a single relay or both relays OFF.  
E.g.: @01 ROF 1 will turn Relay 1 OFF and @01 ROF 2 will turn Relay 2 OFF for the unit with address 01. 
It can also be used to turn both Relays OFF by setting the parameters to be 0: @01 ROF 0.  
 
TON: Open Collector Transistor ON Command 
This command is used to turn a single transistor or both transistors ON.  
E.g.: @01 TON 1 will turn Transistor 1 ON and @01 TON 2 will turn Transistor 2 ON for the unit with 
address 01. It can also be used to turn both Transistors ON by setting the parameters to be 0: @01 TON 
0.  
 
TOF: Open Collector Transistor OFF Command 
This command is used to turn a single transistor or both transistors OFF.  
E.g.: @01 TOF 1 will turn Transistor 1 OFF and @01 TOF 2 will turn Transistor 2 OFF for the unit with 
address 01. It can also be used to turn both Transistors OFF by setting the parameters to be 0: @01 TOF 
0.  
 
ODI: Read Opto-Isolated Inputs 
This command will return the status of both opto-isolated inputs:  

• If Opto-Isolated Input 1 is active, it will return 1. 

• If Opto-Isolated Input 2 is active, it will return 2. 

• If both Opto-Isolated Inputs are active, it will return 3.  
 
CO1 and CO2: Set Current Outputs, in 2 decimal points from 0-2000 (mA) 
This command is used to set the output current values of Current Output Chanel 1 (Iout1) and Current 
Output Channel 2 (Iout2). The parameter is the current value with 2 decimal points, represents as whole 
number. Range 0-2000mA. 
E.g.: @01 CO1 400 will set ~4.00mA on Channel 1; @01 CO2 1250 will set ~12.50mA on Channel 2.  
 
VO1 and VO2: Set Voltage Output, in 2 decimal points from 0-1000 (V) 
This command is used to set the output voltage values of Voltage Output Chanel 1 (Vout1) and Voltage 
Output Channel 2 (Vout2). The parameter is the voltage value with 2 decimal points, represents as 
whole number. Range 0-1000V.  
E.g.: @01 CO1 500 will set ~5.00V on Channel 1; @01 CO2 950 will set ~9.50V on Channel 2.  
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CI1 and CI2: Read Current Inputs, in 2 decimal points from 0-2000 (mA) 
This command is used to read the current input values of Current Input Channel 1 (Iin1) and Current 
Input Channel 2 (Iin2). The return value is the real current input with 2 decimal points, represented as a 
whole number. 
E.g.: If you have a current of 15.50mA on Channel 1 then @01 CI1 will return #01 1550.  
 
VI1 and VI2: Read Voltage Inputs, in 2 decimal points from 0-1000 (V) 
This command is used to read the voltage input values of Voltage Input Channel 1 (Vin1) and Voltage 
Input Channel 2 (Vin2). The return value is the real voltage input with 2 decimal points, represented as a 
whole number. 
E.g.: If you have a voltage of 5.5V on Channel 2 then @01 VI2 will return #01 550.  
 
SAD: Set Address 
This command is used to set address of the device. Addresses are valid from 01-99. A unit will only 
respond if its address in memory is the same as that of the command sent, or if the address of the 
command sent is 00 (Broadcast Address). The address is saved to non-volatile memory inside the 
controller, meaning it will be preserved even after power is disconnect from the controller. 
 
SBR: Set Baud 
This command is used to set the Baud Rate of the RS-485 Port. Parameters from 1 to 10 are valid, 
corresponding to values shown in Table 3. 
 

1: 1200 baud 6: 19200 baud 

2: 2400 baud 7: 28800 baud 

3: 4800 baud 8: 38400 baud 

4: 9600 baud (default) 9: 57600 baud 

5: 14400 baud 10: 115200 baud 

 
The baud rate is saved to non-volatile memory inside the controller, meaning it will be preserved even 
after power is disconnect from the controller. 
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Using the controller as an Arduino: 
 
The controller uses the common Espressif’s ESP32-DevkitC-32D and can be programmed/modify using 
Arduino environment. To add the ESP32-DevkitC-32D to your Arduino IDE, please follow the steps 
below: 
 
1. In your Arduino IDE, go to File> Preferences 
 

 
 
2. Enter https://dl.espressif.com/dl/package_esp32_index.json In the “Additional Board Manager 
URLs” field. Then, click the “OK” button. 
 

 
 
3. Then go to Tools > Boards > Boards Manager… 
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4. In the Board Manager, search for esp32 then press Install.  
 

 
 
5. To program your KTA-332, go to Tools > Board then select ESP32 Dev Module 
 

 
 
 
The pin mapping of the KTA-332 is shown in the table below: 
 

Peripheral ESP32/ Arduino Pins 

RS485 – TX  18 

RS485 – RX 17 

RS485 – EN 5 

I2C SCL 4 

I2C SDA 16 

RELAY 1 14 

RELAY 2 12 

OPEN COLLECTOR TRANSISTOR 1 26 

OPEN COLLECTOR TRANSISTOR 2 27 

OPTO-ISOLATED INPUT 1 33 

OPTO-ISOLATED INPUT 2 25 

GENERAL PURPOSE IO 1 21 

GENERAL PURPOSE IO 2 22 

GENERAL PURPOSE IO 3 23 

GENERAL PURPOSE IO 4 32 

DIP SWITCH 1 36 

DIP SWITCH 2 39 
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DIP SWITCH 3 34 

DIP SWITCH 4 35 

GREEN LED 13 

RED LED 15 

 
Hardware notes: 
 
One drawback of the ESP32 is its weak Analog performance. Therefore, the KTA-332 uses two external 
I2C 12-bit ADC (MAX11615) and DAC (MAX5815) chips to handles the Analog I/O accurately. A basic 
Arduino library is provided with the default sketch to allow DIY modifications.  
 
The external I2C on controller can work with either 3.3V logic devices or 5V logic devices by selecting the 
correct voltage using the I2C voltage switch. Note that this switch will only affect the pull-up voltage of 
the external device.  
 
The 2 relays on boards have contacts rated to 10 A and 30 VDC/250 VAC. At the maximum current, the 
PCB tracks would rise approximately 80°C so the controller can only handle the full rated relay current 
for short periods of time.  
 
The KTA-332 comes with 4 DIP Switches. These switches all have hardware 4.7kΩ pull-up resistors. 
Therefore, when the switches are OFF, the signal is HIGH and when the switches are ON, the signals are 
LOW. At current firmware version (1.0), there is no functions assigned to these DIP Switches.  
 
The KTA-332 also comes with 4x GPIOs which are connected directly to the ESP32. Thanks to the ESP32’s 
ability to set multiple functions to a pin, you can assign different functions to these GPIOs. With default 
hardware, each GPIO has a 10kΩ pull-up resistor to 3.3V and a series 4.7kΩ current limiting resistor. 
However, each GPIO can also be set up with pull down resistor or act as Open Collector Transistor 
Outputs or additional UART output. At current firmware version (1.0), there is no functions assigned to 
these GPIOs.  
 
For help with programming and modifying the default sketch, please contact 
info@oceancontrols.com.au. 
 
 
 

Hardware Revision History: 
 
KTA-332 v1.0: initial release 
 

Software Revision History: 
 
Firmware v1.0: initial Release. 
 

 


